Follow

HTTPS/SSL is not working.

Subject:

When accessing the QuantaStor Web GUI using HTTS you will see a "Not Secure" message as seen in the screenshot below:

 

Screen_Shot_2017-03-17_at_10.10.29_AM.png

 

Detail:

QuantaStor uses Self-signed certificates. It looks like starting with Chrome 56.x Google is not showing the SSL certificate except under the Developer tools as shown in the below screenshot:

Screen_Shot_2017-03-17_at_9.30.56_AM.png

 

 

If you are using a Chrome browser connected to a QuantaStor system and you see "Not Secure" message this does not mean HTTPS is not working, but that the certificate is self-signed and not from a trusted root authority that Google is aware of.

Note: This symptom only occurs on Chrome browsers and can be avoided by using a different browser.

SSL-DeveloperTools-Certificate Details

More info on Chromes decision to make this change and how to view the certificate here:
https://productforums.google.com/forum/#!topic/chrome/su0hEzupG1Q;context-place=topicsearchin/chrome/category$3Aim-not-sure
https://productforums.google.com/forum/#!topic/chrome/dDTJYdWTUxM;context-place=topicsearchin/chrome/category$3ABeta%7Csort:relevance%7Cspell:false

Note: You can install your own signed/Trusted Certificates for the QuantaStor Storage as detailed in our documentation here:
https://wiki.osnexus.com/index.php?title=Custom_SSL_TLS_Security

 

 

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments

Powered by Zendesk